Skip to content

Getting Started

Setting up your Arduino IDE

Make sure you have the latest Arduino IDE.

For Windows we recommend the installer.

When your Arduino IDE is installed, it might be necessary to restart your computer. In some cases, if you don’t restart your computer, the IDE will not launch.

Board files

When your IDE is all started, we should add the URL before we can install the libraries. Click on File > Preferences and at the bottom you should see ‘Additional Boards Manager URLs’. This is where you need to paste the following URL:

Stable

AVR (Moja, Mbili, Ndogo, Tatu)

http://downloads.sodaq.net/package_sodaq_avr_index.json
SAMD (Sara SFF, Sara AFF, Explorer, Autonomo, One)
http://downloads.sodaq.net/package_sodaq_samd_index.json

Beta

SAMD (Sara SFF, Sara AFF, Explorer, Autonomo, One)

http://downloads.sodaq.net/test/package_test_sodaq_samd_index.json

Warning

The Beta boardfiles are not fully tested! By using these boardfiles you can help us test the compatibility.
Let us know on our forum if you have any issues.

Arduino

Note

You can use multiple URLs at the same time.

When you have pasted the URL, click ‘OK’ and you’re ready for the next step.

Installation

Click on Tools > Board:… > Boards Manager…
Search for SODAQ.
Click on a board collection, an install button will appear.
Install the latest version of your selected board collection.

Select Board and Port

Select your board from the menu:
Click on Tools > Board:… > your board

Connect your board to your computer.
Select the com port of your device.

Don’t let the name behind the port confuse you. The names will not always be as you expect.
Example: SODAQ ONE and Arduino Zero have the same Cortex-M0 microcontroller.
The name behind the port will most of the time show the first SAMD board in the list. e.g. SODAQ SARA, Arduino Zero and not SODAQ ONE as you would expect.
Always select the correct board under the board selection!!
Selecting a board with same microcontroller will compile and upload, but it will NOT work and may brake your device!!

Libraries

Library manager

Click on Sketch > Include Libraries > Manage Libraries…

In most libraries you can find some examples.
In the Arduino IDE go to File > Examples > Sodaq_xxxx > example

GitHub

The latest verion of the library is always on GitHub.
You can find all our opensource software on our GitHub page.

Serial Monitor

For most applications we need to enable “Both NL & CR”.
Or send the commands new line and carriage return manually.